Degraded Performance on the Workflow Engine
Incident
2026-03-04T20:38:00.0000000Z
Degraded Performance on the Workflow Engine
Status: closed
Start:
2026-03-04T16:45:00.0000000Z
End:
2026-03-04T20:38:00.0000000Z
Duration: 3 hours 53 minutes
Affected Components:
App Xchange Platform
Workflows
Update
2026-03-04T16:45:00.0000000Z
2026-03-04T16:45:00.0000000Z
Our workflow engine is experiencing slower than normal processing. We are aware of the situation and working to resolve it.
Resolved
2026-03-04T20:38:00.0000000Z
2026-03-04T20:38:00.0000000Z
We have identified the root cause of the performance issue. These have been addressed and services have returned to normal.