Delayed Flow Status Updates

Incident

Delayed Flow Status Updates

Status: in progress
Start:
Affected Components:
App Xchange Platform Workflows Schedules
Update

We are experiencing delays in schedules that rely on flows to complete. We are also seeing delayed updates to the UI from flows finishing.

We are looking into the issue, but a queue has accumulated causing delays of 20-mins.

Update

We have identified the issue and taken steps to mitigate. We have also scaled up the platform to process through a queue that accumulated. We are running a 11-min delay at the moment. We will provide updates as the platform returns to normal.

Update

We continue to monitor the platform and work down the queue. It is scaled up and about 1/3 of what it was. We will provide an update when it returns to no delay later this afternoon.

Update

We are still monitoring. The queue is back to normal ranges, but we are keeping this incident open to perform additional maintenance.

Update

Workflow queue has returned to normal ranges. However, we are leaving this incident open overnight to conduct additional maintenance.