Delayed Flow Status Updates

Incident

Delayed Flow Status Updates

Status: closed
Start:
End:
Duration: 5 hours 8 minutes
Affected Components:
App Xchange Platform Database API Workflows Schedules
Update

We are experiencing delays in schedules that rely on flows to complete. We are also seeing delayed updates to the UI from flows finishing.

Root cause is related to a Vista service pack that released overnight to customers. We have identified the issue, but a queue remains. We have scaled up to process that queue more quickly.

We expect delayed updates for a few more hours.

Update

We have been working through our backlog as fast as we can. There was a very large backlog so it took some time. Flows are still running but we have a backlog for the next 15-minutes. We continue to monitor.


Resolved

Queue has returned to normal ranges. All schedules and flows are completing in expected timeframes. This incident has been resolved.