Delayed Flow Status Updates

Incident

Delayed Flow Status Updates

Status: closed
Start:
End:
Duration: 1 hour 13 minutes
Affected Components:
App Xchange Platform Workflows Schedules
Update

We are experiencing delays in schedules that rely on flows to complete. We are also seeing delayed updates to the UI from flows finishing.

We have identified the issue, but a queue remains. We have scaled up to process that queue more quickly. We expect delayed updates for about another hour.

Resolved

Queue has returned to normal ranges. All schedules and flows are completing in expected timeframes. This incident has been resolved.