Elevated Error Levels and Processing Delays

Incident

Elevated Error Levels and Processing Delays

Status: closed
Start:
End:
Duration: 17 hours 3 minutes
Affected Components:
App Xchange Platform Database API Workflows Schedules
Update

We are experiencing elevated error levels since about 11am CST that is impacting legacy services and causing performance delays. We are actively investigating the issue.

Update

We have identified the issue and determined that it is limited to the Procore <> Vista legacy integration.

This incident is now limited to the Procore <> Vista legacy integration.

The Viewpoint services for the Procore <> Vista integration are failing to complete at a higher than normal rate. It is not all customers and it is not every hourly run, but the failure rate is higher than normal. Customers would experience a delay in data transfer to Procore and a higher than normal failure rate when exporting (the error may say something generic like failed entirely).

We expect some database maintenance to complete overnight. We will continue to monitor the situation. We plan to leave this incident open and provide an update in the morning.

Resolved

Maintenance completed around 6:51pm late yesterday. Legacy Viewpoint syncs for the Procore <> Vista integration started working normally after that. They ran overnight and through this morning as expected.

This incident has been resolved.