Some Workflow Runs are Failing

Incident

Some Workflow Runs are Failing

Status: closed
Start:
End:
Duration: 4 hours 51 minutes
Affected Components:
App Xchange Platform Workflows
Update

We are actively investigating and issue with our workflow engine than is causing some workflow runs to fail. We will provide updates as we learn more.

Update

We have mitigated the underlying issue and new workflow runs are executing as expected. We are still working on remediating the impacted workflow runs.

Resolved

We have identified and addressed the issue. We are continuing to monitor, but are fully operational since 10:55am CST. The service disruption was limited to the workflow engine and a subset of workflows. End-user would see a workflow that appears "stuck" in a suspended state or in progress but not completing. We are reviewing impacted customers to remediate the workflows that did not finish as expected.

This incident has been resolved.